Welcome to the official XiiaLive support forum! You can ask questions and get direct support from the developer.

Please note that we are a team with one developer and one graphics designer. We like to personally answer posts but aren't always able to do so as quickly as we would like to. In order to help us become more efficient, please follow the steps below when posting new questions, ideas or bugs.

Please post under one of the following:

QUESTIONS OR IDEAS
If you have a question or idea, start by typing it in the box provided and search below under similar topics to see if you can find an answer. If you don’t find an answer then simply post a new question or idea.

BUGS
If you spotted a bug and you want to let us know about it, first try searching for OPEN bug posts with similar issues and add any details you think might help us with it. Also, make sure to up vote the OPEN bug post so we know how critical it is. If no OPEN bug posts are found simply post a new one.

Posting new bugs

When you post new bugs please give us as many details as you can! This will help us resolve issues quickly and easily.

Common details we need:
  1. What device do you have?
  2. What OS version is it running?
  3. What happened?
  4. What did you expect to have happened?
  5. What steps reproduce the issue?

Don't have the app yet? Get XiiaLive or XiiaLive Pro now for Android! Or get XiiaLive for iOS!
+2
Under review
Peter Fischer 5 years ago in Bluetooth / Controls • updated by Jona (Lead Developer) 5 years ago 0

When the stream finishes buffering, I heard audio for 2-3 seconds, before the audio stream cuts out.  XiiaLive continues to play through the active stream, but no audio is heard.  On previous versions, this was fine.


The audio seems to cut out right as the stream meta data rolls across the Android notification bar.  I'm not sure if this has anything to do with the newly added AVRCP support or not, but the timing looks very suspicious.  This problem does not occur when using headphones.


Additional Information:

Samsung Galaxy S3 

Android Version 4.04 - Stock/Unrooted

XiiaLive Pro version 3.01

Vehicle Subaru Legacy 2012



Answer
Jona (Lead Developer) 5 years ago

Sorry for the super delayed reply! 


First let's see if possibly the new AVRCP 1.3 hack broke BT streaming.

- Turn off the Icy-metadata option under Settings->Stream and try starting a new stream. Let me know if the issue still happens. This should cause AVRCP not to be used by the app since no metadata will be active.


After that test regardless if an issue still occurs try collecting the logs right after the issue happens when streaming. This hopefully will allow me to see a possible cause.

http://support.xiialive.com/topic/38494-how-to-collect-error-logs/