Welcome to the official XiiaLive support forum! You can ask questions and get direct support from the developer.

Please note that we are a team with one developer and one graphics designer. We like to personally answer posts but aren't always able to do so as quickly as we would like to. In order to help us become more efficient, please follow the steps below when posting new questions, ideas or bugs.

Please post under one of the following:

QUESTIONS OR IDEAS
If you have a question or idea, start by typing it in the box provided and search below under similar topics to see if you can find an answer. If you don’t find an answer then simply post a new question or idea.

BUGS
If you spotted a bug and you want to let us know about it, first try searching for OPEN bug posts with similar issues and add any details you think might help us with it. Also, make sure to up vote the OPEN bug post so we know how critical it is. If no OPEN bug posts are found simply post a new one.

Posting new bugs

When you post new bugs please give us as many details as you can! This will help us resolve issues quickly and easily.

Common details we need:
  1. What device do you have?
  2. What OS version is it running?
  3. What happened?
  4. What did you expect to have happened?
  5. What steps reproduce the issue?

Don't have the app yet? Get XiiaLive or XiiaLive Pro now for Android! Or get XiiaLive for iOS!
0
Under review
ans ris (ansris) 2 years ago • updated by Rodrigo (Developer) 1 year ago 1

Hi, i tried on my phone xiialive when i hade jellybean firmware and the metadata were not transmitted over bluetooth, then i update firmware to kitkat and it works! for some reasone i had to get back jellybean and it effectively not works... same version of xiialive app... why ?

0
Under review
Baseer Balazadeh 4 years ago • updated by Jona (Lead Developer) 4 years ago 0
I'm on version 3.0.2. Samsung note 2.

I'VE notice bluetooth streaming suddenly stops. I'll have to force close the app before bt streaming works again. While this is happening I've tested winamp and Pandora just to make sure its not the phone. They work fine.
Answer
Jona (Lead Developer) 4 years ago

Sudden stop you are saying that audio stops being routed to BT device and possibly you are hearing it on your phone? When this happens do you see the XiiaLive that is actively playing?

0
Rockcvn71 2 years ago • updated 2 years ago 0
Ok what I find happens when I adjust my equalizer on xiia app...I notice the current loud-Ness of the music is substantially lower if I move any of the Bass through treble bars up .I'm certain it hasn't always been like this.I've owned quite a few smart phones from epic to note 3.I noticed it on the Samsung note 2 .This is all while I'm using the player and say listening to groove salad station ect.I do have power amp installed and life vibes music fx on my note 3.
0
Under review
javahelpers 5 years ago • updated by Jona (Lead Developer) 5 years ago 0

it`s better if their are in option to execute some scripts info over android..since android it is linux platform

Answer
Jona (Lead Developer) 5 years ago

Could you explain a little more about the script? Are you saying allow the user to edit a share script? The more details the better! :)

0
Answered
dildo 6 years ago • updated by Jona (Lead Developer) 4 years ago 2
Im using 3g on my samsung galaxy s because i have no wifi available,but pirate station and crystal one both connect with no problem
0
Under review
Thomas Forrester 3 years ago • updated by Jona (Lead Developer) 3 years ago 2
XiiaLive Pro (paid) v3.1.0 (I think - your "about" screen should say what the version is, but doesn't. Ah, there it is - found it on the Apps listing on the device; yes, it's 3.1.0) on AT&T carrier version HTC One running Android 4.3.

It used to work perfectly.  Then a couple of updates ago, XiiaLive Pro started dropping the stream (a shoutcast internet radio station) a couple of times within the first 5 to 10 minutes of streaming.  This seems pretty consistent and happens regardless of buffer settings.

Current settings: 
Stream engine: Andriod.
Stream cache length: 5 min
Pre-buffer length:  12000ms
buffer length: 12000ms
connect timeout: 12000ms
read timeout: 12000ms

So what happens is, the stream starts playing, then a couple of minutes in, I hear the "theme" noise as the stream drops.  It is silent for up to 30sec, and then it just starts playing again without another theme noise sounding.  Playback will continue normally, but will then drop again anywhere up to about 10 minutes later (usually 5 to 8 minutes) for another few seconds to around 30 seconds.  Once it recovers from this second drop, it is typically solid after that.

I am on WiFi when this happens.  As the owner of the internet radio station (Girls Rock Radio on SHOUTcast) that XiiaLive Pro is connected to, I can tell you without reservation that there is no buffering at the source.  I also know that other devices on the WiFi network (i.e., laptops, etc) are not experiencing any buffering issues so that eliminates the WiFi router as a source of the problem.

Is there any guidance you can provide in correcting this issue?

And, a small aside - I noticed some people complaining in bug reports here that they loose a stream when driving "out of range."  I think that might be happening to me now, too, and I should add that after first purchasing XiiaLive Pro that NEVER happened.  To get around the issue, I use a power management app that has "themes" like "Home" and "Away" which allows me to set the state of WiFi, bluetooth, mobile network, etc.  So I created a "Car" theme that enables bluetooth, turns off WiFi and turns on the Mobile Network.  If I start XiiaLive Pro with the "Car" theme switched on, I don't have the problem since the device doesn't loose WiFi since it was on the Mobile Network right from the start.  But again, XiiaLive Pro used to always handle the loss of WiFi and switch to Mobile Network just fine.  It was the ONLY App that did, and a BIG reason I purchased the Pro version in the first place.  Any chance of just going back to how things were a few versions back?

And BTW, I am extremely happy with my purchase decision for the Alarm function alone.  XiiaLive Pro has successfully woke me up every day for over a year now and I LOVE it for that.  I just would like to purge this 2x stream drop in the first 10 minutes bug.
Answer
Jona (Lead Developer) 3 years ago
Thanks for the great feedback! I really appreciate that you took the time to write us. 

We really stride to try to make the stream engine as solid and robust as we can. The issue you are now seeing with WIFI to network data switch off not recovering properly is an issue since we do expect it to properly recover and make it feel seamless.

The drop issue you see after 10minutes could potentially be various things. Does that drop happen while you are in one place or moving?  

It would help if you can reproduce those two issues separately and right away do a bug report from XiiaLive->Settings. I say right away so that the logs don't get overwritten.

Now the exciting stuff...we have recently released a beta version of XiiaLive on GooglePlay. This new version has a brand new and a lot smarter stream engine. I'm work on it as hard as I can to make it the best! It would be great if you can try it out and see if these issues still happen and if it works better overall for you. Take care!
0
Fixed
R S 5 years ago • updated by Jona (Lead Developer) 4 years ago 4
Doesn't work on motorola razr.
Answer
Jona (Lead Developer) 4 years ago

This issue has been seen across multiple devices. The main issue is with these devices containing buggy Android media framework. In many cases this issue has been resolved after upgrading to a new version of Android or in other cases simply restarting the device.


Because of this error and the uncontrollable versions of the Android media framework across devices we have been working hard on a brand new stream engine that handles every single area of streaming and playback. This should solve a lot of issues in the near future. Stay put for updates on this new stream engine.

0
Under review
Tim McCarthy 5 years ago • updated by Jona (Lead Developer) 5 years ago 0
Typing Favourites
Answer
Jona (Lead Developer) 5 years ago
Yes, simply find the station you like, start playing it and press the bit ( + ) button on the player. That will save it to your favorites.
0
Fixed
Emre Burhan 3 years ago • updated by Jona (Lead Developer) 3 years ago 5
Skip to next track ~15 times causes Internal error -14 on bluetooth.

Galaxy S4 Verizon KOT49H.14545VRUFNC5

1. Make sure your Bluetooth headset is connected
2. Start XiiaLive Pro
3. Touch the play button on screen
4. Once the station starts playing, touch the 'next track' button on screen
5. Repeat step 4 for about 15 times

Expected: next station starts playing
Actual: internal error -14

Sometimes after skipping to the next track the status text will display 'playing' but no audio.

Experiment results when skipped to next track for...
11 times: internal error
12 times: no audio. Skip again: internal error
13 times: no audio. Skip again: no audio. Skip again: internal error

Reported this same issue some time ago and was informed about the 'press and hold the stop button' trick. The trick still works, however it's dangerous while driving and impossible while riding a motorcycle (helmet with Bluetooth set).

Emailed with an attached bugreport.txt that was created as soon as an internal error message appeared.

I believe this issue is present for more than a year now if not more. Please help.

Thanks,

0
Fixed
yoshi17 6 years ago • updated by Jona (Lead Developer) 6 years ago 0
I've got very poor quality with AAC+. 
The stream is played without interruption but the sound is very crapy, high frequencies are reproduced but with a lot of quatization noise (like if it was downsampled in 8 bit deph), and the low freq present but at a lower level.

If I play the same stream (http://stream-aac.frequence3.net:7070) from an other material (my computer under win7, foobar2000 v1.1.5, or winamp v5.61) I do not have this quality issue.

If I encode an AAC+ file end I play it on my androide device with poweramp the sound is very good.

I think the AAC+ decoding engine of xiialive is bugus.

My device is Motorola Defy, with original android 2.1 (I do not take the time to customiz my rom yet)
Answer
Jona (Lead Developer) 6 years ago
Previous versions of Android such as 2.1 have a bad AAC decoder.  We use the phones decoder for playback.  If you like to test our beta internal stream engine, just go under XiiaLive settings -> Advanced users and switch Internal stream engine to ON.  Remeber that it's in beta state and track information is currently not working....