+7
Fixed

Lollipop App Issues

David Lam 3 years ago • updated by Ralph 2 years ago 11
After upgrading Xiialive Pro to the latest version "with Lollipop support," the app has been crashing on my Nexus 6 (running Android 5.0.2) consistently every time my phone tries to reconnect with the car stereo and the music would not auto play. The app crashes with the usual Android crash message "Unfortunately, Xiialive Pro has stopped." I have never gotten this crash before on versions before the Lollipop support was added in, although autoplay on BT on these did not work on my device either. Furthermore, on the latest version I have also been getting a "LICENSING FAILED! We apologize, Xiialive Pro was unable to verify your purchase. Please check to see if a network connection is available. Error -46767." message soon after I try restarting Xiialive Pro. Like the crash, I also never experienced this before until the recent versions. So here are the general sequence of events:

1. Turn on BT on phone
2. Turn on BT on car stereo
3. Wait for phone to connect to car stereo
4. Once connected, wait for Xiialive Pro to crash, dismiss the message, and then start the app
5. Start streaming music (generally the Licensing failed message appears after a couple seconds of playback, in which the music stops, and happens 1-2 times, but goes away after dismissing them a couple times)

As you can see, it gets quite bothersome to start streaming my music since there are so many crashes and interruptions in the way. I have tried uninstalling the app and reinstalling it from the Google App store from scratch and that did not fix the issue. Note that this is a legitimate version bought from Google Play, and an Internet connection was indeed available at the time the app was opened (as I said before, I never had this problem until recently.)

Any ideas how these can be resolved?

Thanks!

Answer

Answer
Fixed

Hey guys, the mentioned issues should now be resolved. If for some reason you are still having issues please let us know.

Started
Hey, thanks for the feedback. 

The licensing error message you provided helps a lot, I can see why the licensing issue is happening. Now I need to figure out how to fix it.

About the BT issue, I do see the error and we will be fixing it for the next update hopefully this week or early next week. Sorry for the inconvenience.  
Appreciate the response, glad that the information was helpful. 
Hopefully the issues can be fixed soon so I can get this working again. 
Thanks so much.
Hey, I have resolved all your reported issues and I'm shooting to do an update hopefully today.
That's awesome! Thank you. :)

I just tested this and it does look like it's working properly without crashes or licensing errors. That said, I am kind of back to the original situation where it autoplays (the app will show that it is playing and the duration will keep moving) but there is no sound coming out of the BT speakers. In those cases I usually have to stop the playback and then resume it, and that will bring the sound back. In this version it seems to work better since if my connection cuts off and it reconnects the sound is usually back. This usually happens anyways because I am on the fringe of my Wi-Fi coverage while driving out of the house, and generally it disconnects after leaving my house, which somewhat works in my favor.
Have you seen this issue as well?
Hi- I am having issues with Xiia and my Nexus 6 as well. While using the app, all works fine as long as Xiia stays on screen, but once it is running in background and/or I am doing other things on my phone, the stream will play a few seconds and then cut off, tries to connect several times and then max tries reached, etc. All I have to do is open it from status bar, push play and it works immediately. I thought it may just be a particular stream, but after trying multiple streams I get the same result. I absolutely LOVE Xiia and I am going nowhere. I just want to see if this can be fixed. Thank you! Nexus 6, Lollipop 5.1.0
Hi.
v3.3.0.4, Lenovo K3 Note running android 5.1. After some time not working, not using Xiia, i press play on widget it gets error message . Sometimes with this error phone restart automatically. After that phone not working correct. Did not turn off display, only shows lockscreen. I do restart phone. It takes lot of time. After minutes it start and working fine, but i get some settings reset to default.
+1
Also having an issue. I stream from a pls file, switching from wired headphones to bluetooth frequently. Often the app will start up with a white screen and not advance.
I will have to then clear associated app data and restart, it then comes up without an issue.

Nexus 6
XiiaLive (free) Version 3.3.0.4
Android: 5.1.1 build LYZ28J

I have been using the app every day since I discovered it, and probably have to do this 3 or 4 times a week.

If there is a way to get debug data let me know and I'll provide all I can.
Answer
Fixed

Hey guys, the mentioned issues should now be resolved. If for some reason you are still having issues please let us know.

+1

Awesome...thank you! I'm now on Marshmallow 6.0 and I have zero issues with Xiia. Love it- couldn't be happier. Use it daily! Thank You so much for what you do, I really do appreciate it! Xiia's #1 fan!

Hi Amanda! Apologies for any late response. You're very much welcome! Please don't hesitate to reach out for us for any other concerns. Thank you!