Buffer issues

pim 12 years ago updated by Jona (Lead Developer) 12 years ago 2
Hello, I'm testing the beta version and I don't really understand how the buffer works. I've been playing a lot with the prebuffer length and buffer length but it seems to change nothing at all. The progression status bar (in light grey) has always the same size even if I change the buffer settings.
The only way I found to really increase the buffer size (have a larger grey status bar) and avoid skips when driving is to setup my own icecast server and change the buffer in the server itself. But with that, I have another problem I'll try to explain you.

  1/ I set the burst size (buffer) of my icecast server to :
  <burst-size>393216</burst-size> (= 384 kb)
If the connection is lost during some seconds (which you can do with setting wifi off 5 seconds then on), everything works fine with the smart recovery ON : the stream continues

2/ I set the burst size to something bigger :
  <burst-size>524288</burst-size> (= 512 kb)
Now the light grey bar is larger and buffer is good enough for me.
BUT if the connection is lost during some seconds, when the datas come back, the smart recovery will load again the whole buffer size. This will result in hearing once again a part of a song I just heared before the data connection was lost.

 I don't know if it's clear enough as my english isn't perfect :)
To resume : how can I have a better buffer (= a bigger light grey bar)
and why when setting the server buffer size to something larger than 384 kb the smart recovery plays a part of a song 2 times when connection is back ?

If you want I can give you my server adresses to test
This was made on galaxy s3 with your last beta on a 48kbps aac+ stream



Changed the look back recovery time to be larger.  The fix will be part of the next release.

Awesome feedback! Thanks! Ok, something important first; When using FFMpeg stream engine you will currently not get the gray bar showing how much buffer is available.  However we will add that feature to FFMpeg soon!  If you haven't selected that stream engine you should be able to see the gray bar. However we automatically use FFMpeg if the stream format is other than AAC, AAC+ or MPEG.

Ok, so about the server settings you are using.  Great info by the way. Smart recovery is beta but going strong to be none beta soon! Anyways! The current look back time for trying to recover is about 30 sec and if it fails to recover it just appends it to the end of the buffer. I might have to look over this logic a bit... Could you send me the URL to your server with the large burst size? You can email me privately if you like the link.  jona@visualblasters.com.

By the way what you think of the smart recovery?

Thanks for the email.  I did test your link and was able to see the issue. I have increased the low value of 30 sec to 2 min and things are now good...  Next update it will have the fix. Thanks for the feedback again!


Changed the look backrecovery time to be larger.  The fix will be part of the next release.


Changed the look back recovery time to be larger.  The fix will be part of the next release.