0
Under review

losing metadata

Denvernate 7 years ago • updated by Jona (Lead Developer) 7 years ago 9

I'm still losing metadata, this has been happening with every version after 2.1.8.  It will show, then disappear intermittently.  It might show song title info, no station info, or the opposite, or neither.  It might reappear when the next song plays, then gets wonky again.  It's not the station, I'm streaming my own radio feed that has solid metadata info.  


My phone:

Droid 1

Kernel: 2.6.32.9-cm-stk

Android ver. 2.2.1

CM 6.1.2 


www.radiospinnaker.com

http://76.73.125.26:8067

It happens in the widget.  If you open the widget to player, the meta info is always there (in the player).  I think had the internal stream engine off but I'm not 100% sure.  Don't know if this is an issue, but I'm using it landscape with the Motorola window dock.  I'll try installing the new version and use the internal stream engine on my way home from work tonight and report back.

Thanks for the info.  That's good news for me that on the player you have the correct metadata :)  In regards to the widget well it could be very possible.  I don't think internal stream engine will make a difference in this case... 

I tried with and without the internal stream engine, no change.. still losing metadata in the widget.  Back to ver. 2.1.8 for me I guess.  That version never loses the info. 

Yes I was afraid that wouldn't fix it.  If you can figure out how to reproduce the issue every time and how you are doing it please let me know so that I can try to reproduce the issue and try to resolve it. It might have to do with the custom ROM. 

FYI, I tried CM7.1.0-RC1 and Liquid Sholes 2011806.122403, same problem.  It actually got worse on CM7, forcing me to revert back to version 2.17.  All you should have to do is install one of these builds and move the phone from portrait to landscape to see the issue.  Doesn't matter if you use internal stream engine or not, problem exists.

Let me make sure I understand. The metadata loss you are talking about has to do with the home screen widget correct?

Yes, the metadata is fine in the player, but disappears on the widget.

I'll take a look to see if I can figure out to reproduce the issue... 

Could you reproduce the issue and imideately capture the logs on the phone?  This will help me see what is happening.


http://xiialive.userecho.com/topic/38494-how-to-collect-error-logs/