На рассмотрении

Can only stream via WiFi

Andres Millares 12 лет назад обновлен Jona (Lead Developer) 11 лет назад 26
Anyone know why streaming works only over WiFi???
It was working fine until two weeks ago so what happpend???



На рассмотрении

Andres, Could you let me know if this issue is still happening to you with the latest release of XiiaLive v3? Otherwise I'll be closing this topic. Thanks!

Have you recently got an update for your device? What Android version is it running? Could you let me know how it is not working? What errors do you see?

 Sorry to jump in on this post but i have the same issue.  It has done this for awhile for since i upgraded to ICS 4.0.3 on the Samsung GS2. Just stopped loading any streams unless its on wifi.  It just retries over and over so we may have the same issue Andres.

I have the BETA version.  I want to get the full version as i love this app but its not worth me getting if it only works on wifi as i would often use it in the car.

Is this a known issue on some handsets Jona?

I currently use Samsung GS2 as my main phone running ICS 4.0.3 and it runs perfect.  Mine is a T-Mobile phone. I'm thinking this is an issue with some setting on the phone? Could you try restarting the phone and trying again? Also, what is the error message you see?

 I updated to the latest version on the play store and still the same.

I am with Bell.  I have tried more then once over the past few months and it doesnt make any difference about restarting.  I usually listen to Digitally imported but it does it with any station. 

If i go to the digitally imported website and click the listen now links and select xiia as the player it works just fine and plays but wont work if i search for the radio station in the player and select it.

It just says request time out.

 No scrub that i mustn't have been completely off wifi as even from the website it still wont play. When i was connected to wifi it would though.

It says invalid parameter or request timed out. Works great on wifi though.

So you are using the beta version? I would recommend you find a station via XiiaLive and click it to start playback right after you get the issue reproduced you collect the error logs. http://support.xiialive.com/topic/38494-how-to-collect-error-logs/

Ok done.  I was listening to vocal trance on wifi which was working great.  I turned wifi off. Waiting till it had switched off then selected the same station.  It just did its looping of trying to play so i generated the logs and have emailed them to you.

Thank you for your help! Once its working im definitely getting the full version.  I love the new design layout as well.  Its awesome.

Was able to see the issue but I'm not sure yet of a solution. There is an error when connecting HTTP error 502 Bad Gateway.  This should like something weird on the device being unable to connect to server. Are you able to open webpages on your browser? Can you try using the FFMpeg stream engine? You can change it under settings->stream.

Your the man :)

That fixed it. 

I had no trouble getting web pages or anything else but making that change in the stream fixed the issue.

Is the full version of the Xiialive Beta out now?  I saw the old version of Xiialive is there but has the re-skinned version been released yet?

Cool, but I'm still puzzled why you are having the HTTP 502 error...  Do you have any apps that are virus or app monitors running on your device?  Somehow something is blocking the network from working via "Java layer".

We are getting ready to release officially V3.0.0 hopefully soon!

Oh that could be the reason... They have like firewall settings and things that mess with the network connections... I would play around with the settings.. Or uninstall it just to test.


 I will give that a shot.  I dont have the firewall switched on but never know with anti virus software! I have had to uninstall it on many computers because of firewall issues even when the firewall is off.  Avast is usually pretty good though.

Cool! Yes, Avast is a good program. Have used it way back when it started! :) Let me know how it goes...

I stream via Ethernet on past and current versions of XiiaLive and I've never had a problem.

I've used WiFi on my FV-1 Android TV v2.2(Android v2.2) box and it works fine whether using Ethernet or WiFi.

 I also have recently had this problem on multiple android phones.  I have gone through many operating systems with them both, and had the same problem with every version of Xiia I tried (beta, paid, new 3.0.0 release).  Even after a clean install to stock operating system (ICS 4.0.4) was still having the problem.  Switching the stream from android to FFMEG fixed the problem on both phones (now running various iterations of 4.1.1 JB).  THANK YOU!  HAVE BEEN VERY SAD FOR A MONTH NOW NOT FINDING A FIX FOR THIS!

Thanks for the info! Are you using some type of firewall/virus protection app on the device? Like Avast? What error where you seeing before?

На рассмотрении

Andres, Could you let me know if this issue is still happening to you with the latest release of XiiaLive v3? Otherwise I'll be closing this topic. Thanks!

I also have this exact same problem with the newest version! I have ICS 4.0.3 on my phone and it gives me the same 502 error over 3G using the "Android" stream mode. Wi-Fi with "Android" mode or switching to FFMpeg works fine. I have no anti-virus programs installed on my device. I do have a task-killer but it only activates every 30 minutes. I tried both the paid and free versions. (Seems like it might be a 4.0.3 bug?)

The lack of seeking on FFMpeg is a real downer so if you could get FFMpeg seeking working and/or 3G "android" mode fixed, I would be so happy. 

Thanks for your post. I'm still not sure why on some devices 502 message is happening. Something weird is happening internally with Android. In regards to FFmpeg, I'm already working hard at it trying to add smart recovery and seeking support.  Hope to finish it soon.


I have exact the same issue. Since my phone upgraded to Jelly Bean I've been getting 502 error over 3G. Switching to ffmeg works, but it is stated that it doesn't support smart recovery... It's sad, I use Xiia Pro in my car because of its large buffer and the smart recovery feature..

Xiia v3.0.1

Thanks for the feedback... We have plans to move our network connection code down to low level to avoid these types restrictions applied by networks such as At&t. That should resolve various issues...  I'm currently working on that hopefully I can have something soon.

Hello, first of all - great job! Very nice application.

As others, I have the exact same problem. FFMeg stream works fine over 3G, Android does not. I'm on Bell Canada network, Samsung Galaxy S3, Jelly Bean (4.2.2). My biggest issue is that when the stream is switched to FFMeg, I'm not able to stop/pause using bluetooth button. That's kind of an important feature for me and I'd really appreciate if you could fix it (or make Android stream work over 3G).


Thanks for the feedback. Some devices seem to block localhost servers. Essentially that is how we are able to stream using Android stream engine. You should check that you have no ad blockers or virus protection apps blocking these localhost ports.

I'm already working on a much more advanced stream engine that will no longer depend on Android media services and have the type of issues you are reporting.  This new stream engine will decode using hardware too to improve battery life. Also, it will include recording :).  When will it be released? Well, I can't give any dates yet cause generally takes longer than my estimates.

Hello, I need your help! Today's update totally screwed up my phone. It freezes while playing any radio station. I need to return to the previous version! Where can I download it from? Thanks 

Sorry, for the previous post. The problem is with my phone. Apparently, when it streams audio via A2DP, it loses WiFi. If I connect via cellular data or do not stream BT, everything works fine.

The original problem still exists. And I don't have any ad blockers or virus protection apps. BTW, which port are you using for Android stream engine?

Can you post this issue on a new thread? Just makes it a bit easier for me to follow up and keep track of issues... :P The issue you are having could potentially be with the device? Try reproducing the issue and capturing the logs to send it to us. The port we use is a random one provided by the OS. 

Сервис поддержки клиентов работает на платформе UserEcho