0
Under review

No ID tag info on widget

Denvernate 7 years ago • updated by Jona (Lead Developer) 7 years ago 9
I like the recent changes but have one bug.  I lose the ID tag info in the widget, it displays fine in the player.  Droid1 on stable CM6.

Answer

Answer
Under review
What version of the app are you using? lite or full? How exactly is this happing? Could it be that there isn't metadata sometimes?
Answer
Under review
What version of the app are you using? lite or full? How exactly is this happing? Could it be that there isn't metadata sometimes?
It appears this only happens when the phone is in the Motorola car dock.  The ID tags will come and go but when you open the app all the tags are there.  I'm using the full version 2.1.9.  I tried it with multiple streams and get the same behavior.  I'll keep testing..
Correction.  It's not the car dock, its when you change the orientation (landscape/portrait).
I'm using the Droid1 and have tried reproducing your issue but I'm not having any luck... :(  So you are listening to music on XiiaLive you look at the widget shows the track information and when you open the keyboard and changes orientation the track information disappears?
Maybe it's something on my end.  I'll reinstall/reboot and try a few things.  If you don't hear back assume that fixed my problem :)
Still have this problem even after a clean uninstall/install.  I only use this mostly in the car dock/landscape when driving.  You might get station/song info when you start the widget but it disappears soon.  Mostly you lose both the station ID and song info (it shows unknown) but when the next song plays, the song id comes back, no station ID.  If you touch the widget and open the app, all information is there.  If you open another app and close, both station and song ID's go to unknown until the next song plays.  I only have this problem with the widget in version 2.1.9, not in 2.1.8 back, those all work fine.
Ok, let me to reproduce again... I think I got an idea what's going on...
I'm still having the same widget issue on every version after 2.18, nothing has changed.
If you switched to the internal stream engine you wont have metadata.  The internal stream engine is beta state and doesn't support metadata yet.  Please make sure you have this option set to OFF under Settings->Advanced users. 
I tried that, it still loses the information in the widget, is fine in the player.