+1
Under review

[XiiaLive Beta] No sound after two minutes

srpskarep srpskarep 6 years ago • updated by Jona (Lead Developer) 6 years ago 10

 After two minutes (approximately) sound stops, but data still flows and time running in timeline. I have latest beta version installed on U8120 - eclair 2.1.

Could you try streaming other stations to see if they have the same issue? I would recommend trying AAC and MPEG station... I'm thinking AAC stations are the ones with the issue?

 Yes, station use AAC v2, and this problem persist when XiiaLive use android stream engine. When I change it on ffmpeg there is no problem with stoping but ffmpeg eat too much cpu, so battery runs out much quicker.

Do you have the same issue with XiiaLive Lite?

 Yes, I have the same problem on XiilaLive Lite.

I'm going to update my phone on Android 2.3.7 - CM7 version. I'll post the results.

After updating ROM, I'm unable to download beta version  through Google's store.

I wonder if you can provide me link to download an APK file so I can continue testing?

Sorry for the super delayed post! Can you find the latest XiiaLive official releases on Google Play? Let me know if it works for you.

Updating ROM doesn't do a trick. But latest update of XiiaLive lite work just perfect:)

By the way I think that I found out what cause the problem...
The station use the latest HE-AAC v2 with Parametric Stereo, at very low bitrate.

For some reason low bitrate was problem for previous versions of XiiaLive, but now, as I said, everything working well and I have 2ch instead 1ch, that suggest that new version have latest aac decoder.

Thanks for all your help and for doing great job.

Amazon AppStore has almost approved our app... Should be out in a few days hopefully!