0
Under review

To prevent suspend after while retrying connect

Menghua Cheng 6 years ago • updated by Jona (Lead Developer) 6 years ago 3

while my wifi bandwidth is not good, xiialive (pro) sometimes just stop playing the music even I checked the "unlimited retry" option. but I found the music stream continue playing after I wake up the phone by  unlock the screen, in the time I saw the buffer always shows about 93%~95%. I suspect the app just lost the wake lock since xiialive is buffering and not playing.  so could you add a force "wake lock" option in the settings page? or enable wake_lock when "unlimited retry" option enabled? (HTC incredibleS)

What Android version is your device running?  Could you download XiiaLive Beta from the Google Play Market and see if the issue still occures?

I'm running android 2.3.7 (CM7) on htc incredible S.

the same issue still occurred on the xiialive beta.

also I've done the following test: (all enable unlimited retry)

1.while playing music in background, enable a flash light app (to keep system on), the music always re-play after retrying connect .

2. while playing music in background, no flash light app, screen goes dark, the I hear the do..do.. (re-connect sound ) several times, but no music comes back.  The music stream comes back immediately after unlock the screen.

3. setting->general -> screen timeout -> always on.  the music always re-play after retrying connect .  (but It took battery power to light up the backlight even I don't need it.)


My thought is to enable wake_lock while the app is running,  but disable it while the app retrying connect more than 20 times ( for example).  and keep the wake_lock while "unlimited retry" is enabled.


We keep a wake lock once a play request is received and we don't release it until playback request has reached unlimited retries or the user has hit stop.


I'm thinking this could potentially be an issue with the custom ROM you are using. Some devices I've seen don't handle the power locks properly. For example HTC Wildfire.  Are you running the latest CM7 ROM? If you are active on their dev forums you should post an issue about this...


I'll still look around to try to figure out if somehow we have a bug but I'm sure we don't in this particular area.