0
Under review

Connection Dropped

Rigatoni 7 years ago • updated by Jona (Lead Developer) 7 years ago 13
Just updated to the newest version of XiiaLive and now most of my favorite stations will not play. They are all MPEG format. Just updated to the latest version on my girlfriend's phone and now it does the same thing. It buffers and then says connection dropped. The same stations work fine with a different program.

Answer

Answer
Under review
Mmm... Could you provide the station name?  It could be that this particular station is currently down.  Have you tried searching for the station again and playing it from the search?  Sometimes these stations change servers so links become obsolete.
Answer
Under review
Mmm... Could you provide the station name?  It could be that this particular station is currently down.  Have you tried searching for the station again and playing it from the search?  Sometimes these stations change servers so links become obsolete.

The station that I always listened to the most is called " Kink Aardschok". Like I said though it plays perfectly fine if I use a different program (Resco Radio) so it's not the station, its the new version of XiiaLive.When trying to play the station on XiiaLive, it says "buffering" for a little while then when it reaches 100% it says "connection dropped" and starts buffering again in an almost endless loop. I'm using a Samsung fascinate with firmware version 2.2.1. My girlfriend has the same phone with an older firmware version, the same version of XiiaLive and our favorite stations won't play on there either.

I assume you are playing the AAC version? or MPEG?  Can you reproduce the issue and collect the error logs?

It's very easy here is how:

No, I'm trying to play mostly MPEG stations. I just sent the log as requested.
Did not get the logs.. it was an empty email...
Can you confirm that you can play other MPEG stations that aren't part of your favorites?
Some do. Some don't. Most of them have the same issue.
I tried the internal stream engine. It works sometimes but usually it just says "connecting" and never seems to connect.
Yes, the internal stream engine is currently being optimized! :)

So I noticed that there are two versions of this station on is MPEG and the other is AAC+.  Have you tried using the AAC+ station?  I think that should work just fine.  In regards to the logs you sent me well for some reason every time you sent them they where empty :(  If you have time and would like to give it one more try could you send me the logs right after you reproduce the issue? Thanks!
Forwarded the log to you again and referenced this issue in the email.
Perfect I got it! :) The log was hidden on the email... :P  I'll be sending you a sample apk if you don't mind to test and see if the issue is resolved... I hope it is... Well at least this version will show a lot more logs output data so I can further investigate.
Installed the version you sent. Now it buffers and then says "android media framework failed". Made another log & emailed it to you.
Thanks for the logs... I have added a new update to the Android market.  Could you check that version out and see if you are having any issues with that version?