0
Answered

Xiaalive disappears as banner ads are loaded

XiaaUser 5 years ago • updated by Jona (Lead Developer) 4 years ago 5
I am using the free version of XIAALIVE, Version 3.2.0.6. It's a very nice app, in fact it's the best player I have used. There is a problem, however, that is very frustrating.

When I begin playing a station from the PLAYER screen, everything works as it should until the app disappears (but keeps playing), exactly as if I had pressed my phone's HOME button. The station continues to play, and I can reactivate the app as I would any other app that had been exited by pressing the HOME button (by re-selecting it from the app menu or by selecting it from my phone's pull-down active app list, for example). However, it will usually quickly disappear again and the whole process must be repeated. This usually happens several times before the app finally becomes more stable (after a few minutes).

It seems to have something to do with the loading of some of the banner ads that appear at the bottom of the screen. When I first start the app and begin playing a station (ANY station), the area at the bottom of the screen is blank- there is not an ad there yet. As soon as an ad does appear, the app invariably disappears (as I said, it's as if I had pressed the HOME button). When the next ad appears, it usually happens again. Once the initial ads are loaded and active, the problem usually becomes less frequent. Note that I only experience this bug when viewing the PLAYER screen. If I start playing a station and then immediately switch to any of the other 8 screens (Home, Talk, Music, Local, Search, Favorites, History, or Settings), operation works properly and the player doesn't disappear, even though the same ads display on those screens too.

Also, the problem only happens when I use the app in portrait mode. If I turn my phone sideways for landscape mode, the app works flawlessly in PLAYER view and all other views (Interestingly, no ads ever appear at the bottom of the PLAYER view when in landscape mode, although they can be seen in all of the other views).

I think I have gone through 4 revision upgrades, but the problem has persisted through all of them so the time has come to post this bug report.

My phone is a Motorola DROID RAZR MAXX (not the HD model) running Android version 4.12. Xiaalive didn't work with the previous Android version either.

My question is this: If you can't or won't fix the bug, do you think the paid version, which I assume will have no ads, will work properly on my phone? I have no objection to paying for this otherwise fine app, but I would like some assurance that it will work correctly.

By the way, I use the player almost exclusively for listening to OTR (Old Time Radio) shows and other talk stations. The built-in equalizer, which many other players don't have, is valuable for adjusting the sound of the often lousy audio of old radio programs.

Answer

Answer
Answered
Hey sorry, for taking so long replying... :/ I checked the logs you sent and it seems to be a bug with your device OS version. This bug is causing certain ads when shown to cause a crash on a WebView which holds the ad. This crash causes our app to completely crash... The issue is not malicious ads it is simply a bug on the OS.

Are you still having this issue?
Further information:
If I disable screen rotation from the phone's menu
(SETTINGS > SYSTEM SETTINGS > DISPLAY > uncheck AUTO-ROTATE SCREEN)
then the app works reliably as it is supposed to with no disappearing acts, even though it remains in portrait mode.

Your response would be appreciated. Thanks.
I sure wish someone at Xiaalive would at least acknowlege my comments.  Have you absolutely no suggestions as to what might be causing the problem?
Under review
Hey! Sorry for not responding any sooner. I'm a one person team so it is a little difficult to answer quickly. :(

I'll try to look into this issue see what could be going on. It would help big time if you could do a bug report when the issue happens again. So what you would do is, once the app closes on its own open the app again and quickly go to settings and tap on bug report. This will prepare an email. That should hopefully help me out see what exactly is going on.
OK, bug report has been sent from my phone.  Thanks.
Answer
Answered
Hey sorry, for taking so long replying... :/ I checked the logs you sent and it seems to be a bug with your device OS version. This bug is causing certain ads when shown to cause a crash on a WebView which holds the ad. This crash causes our app to completely crash... The issue is not malicious ads it is simply a bug on the OS.

Are you still having this issue?